Sistem Gereklilikleri

EnglishCentral tümüyle web-tabanlı bir hizmet olup bilgisayarınıza herhangi bir özel program kurulmasını gerektirmemektedir. EnglishCentral'ı kullanabilmek için ihtiyaç duyacağınız tek şey genel olarak desteklenen bir tarayıcı yazılımı (bkz. aşağıdaki liste) ve Adobe Flash Player sürüm 10 veya yukarısıdır. Son sürümü buradan indirebilirsiniz.

EnglishCentral'ı kullanabilmek için 1 Mb/saniye Internet bağlantı hızına sahip olmanızı öneririz.

EnglishCentral aşağıdaki işletim sistemlerini ve tarayıcıları desteklemektedir:

İşletim Sistemleri Windows XP, Vista, 7
MacOS 10.5, 10.6
Tarayıcılar Internet Explorer 7.0 veya üstü
Firefox 4.0 veya üstü
Safari 5.0 veya üstü